Urban Massage - Failing transactions
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Dec 24, 2023 - 10:59 UTC
Monitoring
The processor has identified the fix and implemented this. We have enable the brand and will continue to monitor sales.
Posted Dec 22, 2023 - 14:50 UTC
Investigating
We are currently seeing all transactions for Urban Massage fail currently. We have contacted the processor and will update when we can.
Posted Dec 22, 2023 - 11:41 UTC