Temporarily Unable to Issue Wayfair UK Codes
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 08:00 UTC
Investigating
Wayfair UK codes were failing to process so we have temporarily disabled the brand and contacted the supplier for investigation.
Posted Apr 01, 2024 - 08:02 UTC