Unable to issue Greggs orders
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 12:24 UTC
Monitoring
The processor has advised that the issues are now resolved. We have enabled the brand and will monitor if sales go through.
Posted Oct 31, 2023 - 11:57 UTC