Just Eat Intermittent Issues
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 11:56 UTC
Investigating
The brand has temporarily been disabled while we investigate the cause of some intermittent failures that occurred in the last hour.
Posted Mar 22, 2024 - 09:03 UTC