Unable to issue gift cards for some UK brands
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 13:39 UTC
Investigating
We are currently investigating errors for the below brands. We have disabled them temporarily and contacted the processors.
Boots Online
Iceland
Morrisons
Odeon
Posted Apr 29, 2024 - 09:57 UTC
This incident affected: Iceland and Morrisons.