Unable to issue gift cards for some UK brands
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 16:17 UTC
Investigating
We are currently investigating errors when issuing gift cards for some UK brands, including the brands below:

Arsenal Football Club
Ask Italian
Asterley Bros
Homesense
Mango
River Island
The Body Shop
TK Maxx
Waterstones
Zizzi
Posted Jan 11, 2024 - 15:56 UTC