Temporarily Unable to Issue Waterstones
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 08:00 UTC
Investigating
We are currently investigating some failures that occured for Waterstones and have temporarily disabled the brand while this is investigated.
Posted Apr 01, 2024 - 08:01 UTC