Errors when issuing gift cards for National Book Tokens
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 09:00 UTC
Investigating
We are currently investigating errors when issuing gift cards for National Book Tokens. As soon as we have an update, we will post it here.
Posted Mar 25, 2024 - 14:29 UTC