Unable to issue gift cards for several UK brands
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 09:00 UTC
Monitoring
The processor has implemented a fix. We have enabled the brands again and we'll monitor sales going through.
Posted Mar 25, 2024 - 16:49 UTC
Investigating
We are currently seeing errors when issuing gift cards for several UK brands. We've disabled the brands and contacted the processor. The affected brands are listed below:

Boots Online
Iceland
Morrisons
Odeon
Posted Mar 25, 2024 - 16:42 UTC
This incident affected: Iceland and Morrisons.