Waterstones - Currently unable to be issued
Incident Report for Huggg
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 09:28 UTC
Identified
The processor has confirmed they have identified the issue and are working to resolve this, however it is unlikely to be resolved today. We will share further updates tomorrow.
Posted Dec 19, 2023 - 08:06 UTC
Investigating
We are aware of an issue affecting Waterstones codes being issued. We are investigation with the processor currently.
Posted Dec 18, 2023 - 09:26 UTC